All Systems Operational

About This Site

We monitor all Ting services 24 hours a day, seven days a week. In the event of a service disruption, we'll post information here to keep you informed of the current status.

Arizona Operational
90 days ago
99.98 % uptime
Today
Tucson Operational
90 days ago
100.0 % uptime
Today
Catalina Operational
90 days ago
100.0 % uptime
Today
Amado Operational
90 days ago
99.88 % uptime
Today
Douglas Operational
90 days ago
100.0 % uptime
Today
Green Valley Operational
90 days ago
99.88 % uptime
Today
Marana Operational
90 days ago
100.0 % uptime
Today
Mt. Lemmon Operational
90 days ago
100.0 % uptime
Today
Nogales Operational
90 days ago
100.0 % uptime
Today
Oracle Operational
90 days ago
100.0 % uptime
Today
Oro Valley Operational
90 days ago
100.0 % uptime
Today
Rio Rico Operational
90 days ago
100.0 % uptime
Today
Sahuarita Operational
90 days ago
100.0 % uptime
Today
San Manuel Operational
90 days ago
100.0 % uptime
Today
Tubac Operational
90 days ago
100.0 % uptime
Today
Vail Operational
90 days ago
100.0 % uptime
Today
California Operational
90 days ago
100.0 % uptime
Today
Culver City, CA Operational
Encinitas, CA Operational
Fullerton, CA Operational
Solana Beach, CA Operational
Carlsbad, CA Operational
90 days ago
100.0 % uptime
Today
Colorado Operational
90 days ago
99.4 % uptime
Today
Aspen, CO Operational
Basalt, CO Operational
Bayfield, CO Operational
Carbondale, CO Operational
Centennial, CO Operational
Cortez, CO Operational
De Beque, CO Operational
Durango, CO Operational
Glenwood Springs, CO Operational
Grand Junction, CO Operational
New Castle, CO Operational
Parachute, CO Operational
Rifle, CO Operational
Silt, CO Operational
Dolores, CO Operational
90 days ago
99.96 % uptime
Today
Colorado Springs, CO Operational
90 days ago
98.84 % uptime
Today
Idaho Operational
90 days ago
100.0 % uptime
Today
Greater Sandpoint, ID Operational
Ponderay, ID Operational
90 days ago
100.0 % uptime
Today
Maryland Operational
Westminster, MD Operational
New Mexico Operational
Farmington, NM Operational
North Carolina Operational
90 days ago
100.0 % uptime
Today
Fuquay-Varina, NC Operational
Holly Springs, NC Operational
Wake Forest, NC Operational
Rolesville, NC Operational
Sanford, NC Operational
90 days ago
100.0 % uptime
Today
Virginia Operational
90 days ago
100.0 % uptime
Today
Charlottesville, VA Operational
Alexandria, VA Operational
90 days ago
100.0 % uptime
Today
Customer Support Operational
Ting Website, Shop & Your Account Operational
Shipping & Returns Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Scheduled Maintenance
On April 25th from Midnight to 01:00 MT we're planning some scheduled maintenance on parts of the Ting Internet / Cedar Networks network in Glenwood Springs, CO.

Customers who are expected to be part of this maintenance have been contacted directly.

Affected may experience a service disruption on one evening during the maintenance window, after which your service will be automatically restored.

Posted on Apr 12, 2024 - 17:18 EDT
On Wednesday May 1st 2024 from Midnight to 06:00 EDT, we're planning some scheduled maintenance on parts of the Ting Internet network in Fuquay-Varina, NC.

Customers who are expected to be part of this maintenance have been contacted directly. Affected customers can expect a brief service disruption during the maintenance window, after which their service will be automatically restored.

Posted on Apr 17, 2024 - 17:15 EDT
Past Incidents
Apr 18, 2024

No incidents reported today.

Apr 17, 2024

No incidents reported.

Apr 16, 2024

No incidents reported.

Apr 15, 2024
Resolved - This incident has been resolved.
Apr 15, 08:19 EDT
Monitoring - Our technicians are still splicing fiber at this location but most customers should be back online at this time. If not please reboot your equipment, if still not online call our support line at 846-844-4994.
Apr 14, 16:05 EDT
Update - The work on this issue is ongoing. At this time we are going to have to replace a part of the fiber and this will necessitate cutting the entire fiber line which will affect most customers in the Greenbrier area. We will complete the repairs as quickly as possible. During this time some customers will see their services drop, and slowly come back online throughout the day.
Apr 14, 08:58 EDT
Identified - The issue has been identified, the fiber became fused after the power lines hit the fiber. One power line is still down. We are currently working with Dominion to get this line safely off our cable so that we can work on the repairs.
Apr 13, 23:31 EDT
Update - Dominion is reporting that power has been restored. We are still seeing several customers offline. Our techs are en route to further investigate. We will update once we have more information.
Apr 13, 21:38 EDT
Update - We are still looking into this issue. Dominion is on site to repair the power lines and once that is done we can look at our fiber lines. More info will be provided once we're able to get to our equipment.
Apr 13, 14:16 EDT
Investigating - We are seeing a number of customers offline in the Greenbrier area of Charlottesville Virginia. We also see power issues in the area reported by Dominion. One of our techs is investigating the cause. We will update when we have more.
Apr 13, 12:38 EDT
Apr 14, 2024
Apr 13, 2024
Apr 12, 2024
Resolved - The reported damage forced us to move the impacted customers to new positions on our network and that has now been done with all customers now back online. We appreciate your patience while we worked the issues. If you're still experiencing issues please contact Ting Internet Support at 1-844-846-4994 (Availble 24/7) for assistance.
Apr 12, 20:11 EDT
Investigating - About 2 dozen homes are offline in Encinitas CA, mostly around or near Santa Fe Dr. We have reports of some ongoing construction / excavation that may be related, but have not yet confirmed that is the cause of the issue. Technicians are aware and en route to survey for damage. We have no ETA yet as to a fix until the cause has been located and assessed.
Apr 12, 18:16 EDT
Apr 11, 2024
Resolved - The customers we have been in contact with have all reported service is restored. If you are seeing an issue at this time, please contact our support team at 1-844-846-4994 or via live chat at https://ting.com/support

Thank you for your patience.

Apr 11, 13:46 EDT
Monitoring - A patch has been applied and we have several reports of recovery already. If services still show offline, a power cycle of your router may fix the issue. We are still working to verify full functionality is returned.
Apr 11, 13:14 EDT
Identified - We are seeing a network-related event that is preventing some customer in Charlottesville from accessing the internet. We have identified the source of the issue, and engineers are working to apply a patch as a matter of urgency. We are hoping to have the situation resolved ASAP. Users affected by this will have normal LED lights lit on equipment but be unable to access the internet.
Apr 11, 13:11 EDT
Completed - The scheduled maintenance has been completed.
Apr 11, 06:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 11, 00:00 EDT
Scheduled - In Charlottesville, VA on Thursday, April 11th, 2024 from Midnight until 6:00AM ET, Ting Internet engineers will perform scheduled maintenance work on parts of our network.

Customers expected to be part of this maintenance have been contacted directly.

During the maintenance window, Ting Internet services will briefly disrupted for a projected 5 minutes, and then service will be automatically restored. We'll be working hard to ensure the downtime is as minimal as possible. If you have any questions, please contact us at 1-844-846-4994 or visit https://ting.com/support

Apr 10, 16:24 EDT
Apr 10, 2024

No incidents reported.

Apr 9, 2024
Resolved - The issue has been resolved and we are closing this incident.
Apr 9, 09:02 EDT
Monitoring - A temporary solution has been implemented to expedite the restoration of services for all offline customers while the engineers work on a permanent fix. Currently, all previously offline services are now back online. If you continue to experience difficulties, please contact us at 1-844-846-4994 so that we can proceed with individual troubleshooting.
Apr 8, 08:26 EDT
Update - Damaged site has been identified, and technicians have begun repair efforts but due to the mountainous area efforts will be severely impacted. We don't have an ETA due to the severity of the damage to our equipment.
Apr 7, 21:11 EDT
Identified - Technicians are on-site; suspected damage is being assessed. Communications in the area are limited, an estimated time for restoration will be provided as soon as possible.
Apr 7, 18:37 EDT
Update - Techs on site have made progress isolating the issue but still don't have an ETA. We will update you when more information becomes available.
Apr 7, 16:57 EDT
Update - Our Partner has techs onsite still investigating, at this point we have no ETA. We will update you when we have more information.
Apr 7, 13:47 EDT
Investigating - We have identified a different issue in the markets listed for this outage. The issue is not power related. Our partner is sending techs to the location to investigate further. We will update when we have more information.
Apr 7, 11:29 EDT
Update - There are power outages in many of our Colorado markets affecting service for approximately 350 Ting customers. Excel energy is working on this issue but due to high winds they are being cautious and repairs may take 4-12 hours as reported by Excel.
Apr 7, 09:06 EDT
Update - We are continuing to work on a fix for this issue.
Apr 7, 09:05 EDT
Identified - There are power outages in many of our Colorado markets affecting service for approximately 350 Ting customers. Excel energy is working on this issue but due to high winds they are being cautious and repairs may take 4-12 hours as reported by Excel.
Apr 7, 09:01 EDT
Apr 8, 2024
Apr 7, 2024
Completed - The scheduled maintenance has been completed.
Apr 7, 12:00 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 7, 10:00 EDT
Scheduled - On Sunday April 7th, from 10:00AM ET to 12:00PM ET, Ting and Cedar Operations staff will perform maintenance on internal tools used by Customer Support and backend tools used by customers of Ting's Cedar Networks in Colorado.

During this maintenance window Internet data services and Voice phone services will not be impacted. Those services will remain working normally.

During this maintenance window customers will be unable to make payments on Cedar invoices or place new orders. Customer support will be glad to assist you with any updates after the maintenance window is complete.

Mar 22, 15:43 EDT
Apr 6, 2024

No incidents reported.

Apr 5, 2024
Completed - The scheduled maintenance has been completed.
Apr 5, 10:06 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 4, 23:00 EDT
Scheduled - Please be advised that on Tuesday April 4th beginning 10pm through approximately 5am April 5th (TUCSON MOUNTAIN TIME) Simply Bits Ting Infrastructure will be performing scheduled maintenance.

The impact of this maintenance will result in possible Intermittent Outages during this time frame. Once maintenance has been completed, your service will be automatically restored.

We apologize for any inconvenience this may cause, but, we sincerely appreciate your patience as we work to improve our Simply Bits - Ting Infrastructure.

Apr 4, 23:45 EDT
Resolved - This incident has been resolved.
Apr 5, 08:30 EDT
Monitoring - We are starting to see affected customers with their services restored. However, if you still do not have service at the moment, kindly reboot your ONT (Ting Internet Fiber Modem) and router. This should promptly resolve the issue. If problems persist after performing these steps, please contact our support team at 1-844-846-4994 (available 24/7) for further troubleshooting assistance.
Apr 4, 22:15 EDT
Update - Ting Internet Engineers are working on a temporary fix to restore service, which they have estimated will be in place at approximately 10PM ET. We will update you further with information from the field as it becomes available.
Apr 4, 18:09 EDT
Identified - Ting Internet engineers are on site at the scene of the roadside fiber damage. Work in the area has broken our transport fibers, impacting approximately 150 homes. Once the damage has been assessed, we will provide an estimated time to restoration.

Thank you for your patience.

Apr 4, 16:37 EDT
Investigating - Ting Internet engineers are investigating reports of an outage affecting some parts of Fuquay-Varina, NC. We will post more information as soon as possible.
Apr 4, 15:39 EDT
Apr 4, 2024
Resolved - This incident has been resolved.
Apr 4, 13:51 EDT
Monitoring - We are starting to see affected customers with their services restored. However, if you still do not have service at the moment, kindly reboot your ONT (Ting Internet Fiber Modem) and router. This should promptly resolve the issue. If problems persist after performing these steps, please contact our support team at 1-844-846-4994 (available 24/7) for further troubleshooting assistance.
Apr 4, 09:45 EDT
Investigating - We are currently investigating multiple reports of an outage affecting some of our customers in the Westminster area. We believe this outage is due to a wider power outage that is affecting our upstream equipment. We will provide further updates as more information becomes available.
Apr 4, 08:17 EDT
Resolved - This incident has been resolved.
Apr 4, 03:24 EDT
Update - Ting Internet engineers continue to work in the field to restore service to the roughly 75-customers still impacted by the fiber damage. We continue to have all available resources working to resolve this break as quickly as possible.

Due to some complications, our estimated time for repairs to be fully completed has now been pushed back to approximately 7:00PM and we will provide further updates as they become available.

Thank you for your patience.

Apr 3, 20:34 EDT
Update - Ting Internet engineers continue to work in the field to restore service to the approximately 75 customers still impacted by the fiber damage. We have all available resources working to resolve this break as quickly as possible.

Our estimated time for repair is approximately 4:00PM and we will provide further updates as they're available.

Thank you for your patience.

Apr 3, 14:46 EDT
Update - Our Ting staff in the field have completed the majority of repairs, but there is still a small subset of customers that are down due to this Fiber damage. We are currently reviewing what further repairs will be needed to bring those customers back online and will be performing that work this morning. We will provide further updates once the next stage of repairs begin. Thank you for your continued patience.
Apr 3, 08:31 EDT
Update - Repairs are nearly complete; services are expected to be online shortly; however, some remaining repairs are scheduled for completion tomorrow morning.
Apr 3, 05:04 EDT
Update - Our repair efforts are still in progress, with our technicians actively splicing transport lines. Please be aware that our technicians have been on site since 8 AM this morning to resolve the issue, and the repair may take longer than anticipated.
Apr 3, 00:58 EDT
Update - Repair efforts continue. At this time we are in the process of getting new fiber blown through transport cabling, prioritizing work that will restore service to some field cabinets. Fiber splicers are still in place and working to resolve this issue as soon as possible but we have no specific ETR to offer at this time.
Apr 2, 18:30 EDT
Update - Vac trucks have completed exposing damaged conduit and repairs are in still in progress. Techs are working on removing damaged fiber and prepping splice enclosures to work with replaced strands. Apologies for the delay as our team continues to work to repair the physical fiber damage.
Apr 2, 13:04 EDT
Update - Our team in Sandpoint is back on site to continue repairs. No ETA at this time for completion. Thank you for your continued patience.
Apr 2, 10:10 EDT
Update - Our team in Sandpoint has temporarily paused operations due to safety concerns and will resume work later this morning at 7 AM (PST).
Apr 2, 08:58 EDT
Update - Our team in Sandpoint has temporarily paused operations and will resume work later this morning at 7 AM (PST).
Apr 2, 03:01 EDT
Update - Our team in Sandpoint is still hard at work on a repair for our damaged underground fiber cable. Thank you for your patience!
Apr 1, 22:04 EDT
Identified - We have identified the source of the issues. It appears a 3rd party contractor working in the area accidentally hit and damaged our fiber causing the outage. However, we are already formulating a repair plan and we will provide more information as it becomes available.
Apr 1, 21:03 EDT
Investigating - Please note we are currently experiencing a partial outage in our Sandpoint, Idaho market, where a signficant number of customers are currently without service. Our Network Operations and Sandpoint Field Operations teams are already investigating the matter and we will provide an update as soon more information becomes available.
Apr 1, 19:53 EDT