Ting Internet - Partial Outage in Holly Springs NC.

Incident Report for Ting Internet

Monitoring

Repairs have been completed, and we are seeing connections restored at this time. We will be monitoring the connections closely to ensure there are no further issues. Thank you for your patience.
Posted May 26, 2026 - 13:33 EDT

Update

Services should start to restore shortly as our field team continues to work on it. We will update as more information becomes available.

Thank you for your patience.
Posted May 26, 2026 - 12:07 EDT

Update

New fiber has been successfully installed, and crews are now preparing splice cases. Splicing work is expected to begin within the next hour. The current ETA of restoration is 3:00 PM or earlier. We will continue to provide updates as work progresses.
Posted May 26, 2026 - 11:15 EDT

Identified

A fiber cut has been identified and is currently being assessed for repairs. We will provide an ETA as soon as it becomes available.
Posted May 26, 2026 - 10:00 EDT

Investigating

We are currently investigating a service outage impacting some customers in the Holly Springs, NC market. Our team is working to identify the cause, and we will share updates as more information becomes available.
Posted May 26, 2026 - 08:29 EDT
This incident affects: North Carolina (Holly Springs, NC).