We have discovered a solution and it has been implemented - calling tests to affected customers have been ringing and no longer echo. We are continuing to monitor in case the issue re-surfaces.
Posted Nov 17, 2024 - 14:42 EST
Identified
We've identified an issue stemming from one of the circuits managed by our VoIP services provider. Upload traffic is not passing on this circuit, which is resulting in the inbound call problems - we are in contact with them to have this resolved as soon as possible.
Posted Nov 17, 2024 - 14:13 EST
Investigating
We have had multiple business customers in Farmington, NM reporting that inbound calls are resulting in no audio, but callers can hear an echo. We are currently investigating this with our VoIP services provider and our own internal engineers.
No ETA yet for resolution but we will provide updates here as we receive them. Thank you for your patience!
Posted Nov 17, 2024 - 13:51 EST
This incident affected: New Mexico (Farmington, NM).