Simply Bits - Outage in Corona De Tucson ( Tucson, AZ)

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Feb 26, 2025 - 09:01 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2025 - 13:23 EST

Investigating

We are seeing a service outage affecting customers in Corona De Tucson. Investigation is underway and more details will be provided as soon as they are available. We do not yet have an ETA on service restoration
Posted Feb 25, 2025 - 10:20 EST
This incident affected: Arizona (Tucson).