Our technicians have begun the splicing process. We are now seeing services for some affected customers coming back online. We continue to work diligently to restore all remaining services.
Posted Feb 20, 2026 - 16:14 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 20, 2026 - 16:12 EST
Identified
Ting techs are onsite now and have verified a fiber cut. Materials are gathered and repair work is commencing, with a current ETR of 9 PM this evening. We apologize for the length of the outage, and appreciate your patience as we work to repair the damaged fiber lines.
Posted Feb 20, 2026 - 14:07 EST
Investigating
We are seeing an outage affecting approximately 20 homes along and near Redford Place Drive. We have a report of a gas leak in the area that may have digging associated with it that may be the cause of the issue. Techs are en route to survey for fiber damage. No ETR is yet available, as it depends on the extent and nature of damage to fiber lines. More information will be posted here as soon as it becomes available.
Posted Feb 20, 2026 - 11:17 EST
This incident affects: North Carolina (Rolesville, NC).