Ting Internet - Partial Outage in Holly Springs NC.

Incident Report for Ting Internet

Monitoring

Repairs have completed and we are seeing connections restored at this time. We will be monitoring the connections closely to ensure there are no further issues. Thank you for your patience.
Posted May 14, 2026 - 14:47 EDT

Identified

Damage to the fiber line has been identified, and repair work is currently underway. The current ETA for service restoration is 6:00 PM, though our team is working to restore service as quickly as possible. Thank you for your patience and understanding.
Posted May 14, 2026 - 12:53 EDT

Investigating

We are currently investigating a service outage impacting some customers in the Holly Springs NC market. We are investigating the cause and will provide additional information as it becomes available.
Posted May 14, 2026 - 09:57 EDT
This incident affects: North Carolina (Holly Springs, NC).