Durango Voice Outage - Outbound Calling to Toll Free Numbers
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Feb 07, 2024 - 23:42 EST
Investigating
We have identified an issue affecting multiple customers in Durango, causing failed outbound calls to various 1-800 and toll-free phone numbers. We are currently working with our upstream vendor for a resolution on this matter.
Posted Feb 07, 2024 - 16:26 EST
This incident affected: Colorado (Durango, CO).