A fix has been implemented, and we are currently seeing service restored for affected customers. If you are still experiencing issues, please reboot your router and fiber ONT. If the problem persists after rebooting, contact us at 1-844-846-4994 for further troubleshooting assistance.
Posted May 20, 2026 - 11:41 EDT
Update
We are still working on finishing up the maintenance from earlier this morning. Please stand by as we continue to work to resolve any customers that are still offline from the over night maintenance.
Thank you for your patience.
Posted May 20, 2026 - 08:58 EDT
Investigating
Some services remain offline after overnight maintenance around the Charlottesville downtown mall. Most offline services related to this maintenance are on or near the downtown mall, or in the north downtown area. Ting techs are in the field working through affected fiber lines, and we apologize for the inconvenience as we work to update the oldest segment of our network in Charlottesville.
Posted May 20, 2026 - 06:54 EDT
This incident affected: Virginia (Charlottesville, VA).