Intermittent Service Drops for Some SimplyBits Customers in Tucson

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 10:01 EDT

Monitoring

Our engineers have implemented a fix, and we have seen improvements to the customers we knew were affected. We are continuing to monitor this, but if you are still experiencing drops in service, or slower speeds, please feel free to give our support line a call for further troubleshooting.

Thank you!
Posted Jun 11, 2025 - 16:59 EDT

Investigating

We are investigating an issue with one of our towers in the North Tucson area (NWST/WalkerRd).

Some customers connected to this tower may experience temporary drops in service or slower than expected speeds. Our engineers are working on resolving this problem and we will update here once we are confident it has been resolved.

Thank you for your patience!
Posted Jun 11, 2025 - 14:10 EDT
This incident affected: Arizona (Tucson).