Centennial Colorado

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 00:36 EDT

Identified

We are seeing a number of customers offline in Centennial at this time. This appears to be due to power outages in area but we will be keeping an eye on situation as well.
Posted Jul 07, 2025 - 16:22 EDT
This incident affected: Colorado (Centennial, CO).