Tucson, AZ - Commercial Customer Fax issues
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Jun 28, 2024 - 16:16 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 28, 2024 - 09:18 EDT
Identified
We are currently experiencing an issue relating to our Fax system. The issue has been identified, and our VoIP Engineering Team is working on a resolution. We apologize for the inconvenience, but will work as swiftly as possible to resolve the issue affecting Fax errors.
Posted Jun 25, 2024 - 19:35 EDT
This incident affected: Arizona (Tucson).