The repairs have been completed and service has been restored. If you are experiencing any issues at this time, please contact our Support team at 1-844-846-4994 for assistance.
Posted Jan 22, 2026 - 17:01 EST
Monitoring
The fiber repairs have completed and we are monitoring for any further issues. Thank you for your patience.
Posted Jan 22, 2026 - 15:41 EST
Update
Repairs are nearly finished, and most customers are already back in service.
Posted Jan 22, 2026 - 15:06 EST
Update
Our splicing team reports work is progressing well, with most customers back online already. The ETR for full restoration is 3PM.
Posted Jan 22, 2026 - 13:19 EST
Update
Our splicing team reports work is progressing well, with some customers back online already. At this time the ETR for full completion is 3PM. We will provide a further progress update by 1PM.
Posted Jan 22, 2026 - 11:28 EST
Update
Our crews have repaired some portions of the fiber damage, as result some customers may be coming online shortly. Crews will be continuing to work diligently to restore service for the remaining impacted area. We currently expect repairs to be completed by 1 p.m. EST. Thank you for your patience.
Posted Jan 22, 2026 - 09:09 EST
Update
Our crews are continuing to splice repairs. Due to the extent of damaged fiber strands, splicing will take longer than initially estimated. Our latest estimated time of repair is 10a.m. EST.
Posted Jan 22, 2026 - 08:23 EST
Update
Our crews have identified substantial damage to our fiber infrastructure and has affected more customers than at first suspected. Crews will be working through the night to restore service. We currently expect service to be restored by 6 a.m. EST. Thank you for your patience
Posted Jan 21, 2026 - 23:18 EST
Update
We are continuing to work on a fix for this issue.
Posted Jan 21, 2026 - 22:32 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 21, 2026 - 22:03 EST
Update
Technicians are onsite and are investigating, thank you for your patience
Posted Jan 21, 2026 - 21:31 EST
Update
We are continuing to investigate this issue.
Posted Jan 21, 2026 - 20:30 EST
Investigating
We are seeing a number of our customers offline in the Wertland St area of Charlottesville and are investigating the issue
Posted Jan 21, 2026 - 19:30 EST
This incident affected: Virginia (Charlottesville, VA).