Ting Internet / SimplyBits - Partial Outage (Sundown) - Tucson, AZ

Incident Report for Ting Internet

Update

We have successfully moved the majority of customers affected to a different sector of our Sundown tower which has restored service to them. There are still 4 customers that were unable to move. Expected time of repair for remaining customers is 8 PM.
Posted Aug 06, 2026 - 14:37 EDT

Identified

Due to storm damage overnight our infrastructure team is working diligently to repair an area around Sundown that was impacted from the weather. We anticipate restoral of services shortly and will post updates here once we have the all clear.
Posted Aug 06, 2026 - 12:17 EDT
This incident affects: Arizona (Tucson, Vail).