On further examination, some services were still offline after our previous update due to the nature of the repair work involved in fixing a initial group. Those service are back online at this time as well. At this point all known widespread issues in Wake Forest have been resolved and repair work is complete. If you continue to see further issues please get in touch at 1-844-846-4994 so we can proceed with individual troubleshooting.
Posted Sep 10, 2025 - 17:53 EDT
Monitoring
This issue has been resolved and all customers are back online. We will monitor this for a short time.
Posted Sep 10, 2025 - 12:57 EDT
Investigating
We are seeing a small outage in Wake Forest NC Willow Deer area affecting around 10 customers. Our techs are in route and we will have more updates to follow.
Posted Sep 10, 2025 - 09:20 EDT
This incident affected: North Carolina (Wake Forest, NC).