Power outage detected in Martha/Jefferson area - Charlottesville
Incident Report for Ting Internet
Resolved
The power outage we are experiencing in the Martha/Jefferson area has now been resolved, and Internet service has been restored.
Posted Jun 19, 2022 - 15:51 EDT
Update
Update: Dominion Power is working to restore connectivity to our customers in the Martha/Jefferson area, ETA is approximately 1-6 PM EST.

You can check the status of the repair at; https://outagemap.dominionenergy.com/external/default.html

Thanks for your patience at this time.
Posted Jun 19, 2022 - 13:33 EDT
Identified
Dominion Power is working to restore connectivity to our customers in the Martha/Jefferson area, ETA is approximately 1-6 PM EST. Thanks for your patience at this time.
Posted Jun 19, 2022 - 13:02 EDT
Investigating
We have detected a sudden loss of power in the Martha/Jefferson area. We are currently investigating this issue and will have more updates shortly. We apologize for any inconvenience caused.
Posted Jun 19, 2022 - 11:12 EDT
This incident affected: Virginia (Charlottesville, VA).