Simply Bits- Tucson AZ - Phone System Outage affecting Commercial customers (Inbound and Outbound)
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted May 09, 2024 - 13:20 EDT
Update
We are continuing to investigate this issue.
Posted May 09, 2024 - 13:20 EDT
Investigating
Please be advised that we are currently experiencing a Technical Phone System issue affecting our Commercial Customers in Tucson. Our Communications Engineers are diagnosing this issue in order to repair the problem as quickly as possible. We apologize for this disruption and inconvenience while we work to make repairs.
Posted May 09, 2024 - 12:46 EDT
This incident affected: Arizona (Tucson).