FVNC Maintenance Overrun

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 12:52 EDT

Monitoring

All affected customers should be online at this time. We will continue to monitor the situation for a while before closing.

Once again we thank you for your patience this morning.
Posted Sep 23, 2025 - 10:43 EDT

Identified

Our scheduled maintenance on the Ting Internet network in Fuquay-Varina, NC, began last night and is still ongoing. This work is necessary to move fiber connections to accommodate the Hilltop Needmore road construction project. Our work in this area has continued throughout the night and has gone longer than expected. We are continuing the work here to restore service.

We thank you for your patience. Once the maintenance is completed, your service will be automatically restored.
Posted Sep 23, 2025 - 08:59 EDT
This incident affected: North Carolina (Fuquay-Varina, NC).