Outage in Fuquay-Varina, North Carolina

Incident Report for Ting Internet

Monitoring

We have put forth a fix that should have almost everyone back online. Please power cycle your device and if you continue to be offline and reach out to support at 1-844-846-4994 if you still are unable to connect.

Thank you for your patience as we continue to monitor the fix that was put in place.
Posted Mar 27, 2026 - 11:39 EDT

Update

We have located the damage to the Fiber lines and are beginning work to restore service with hoping to restore service as quickly as possible. We will post updates as more information becomes available.

Thank you for your patience.
Posted Mar 27, 2026 - 10:59 EDT

Investigating

We are currently investigating an outage in Fuquay-Varina, North Carolina. Please stand by as we look into the impact and cause of the outage.

Thank you for your patience
Posted Mar 27, 2026 - 10:40 EDT
This incident affects: North Carolina (Fuquay-Varina, NC).