Service is back. We've confirmed the affected connections in Wake Forest, NC are online again, and we're keeping an eye on the network for a little while before we close this out.
Thanks to everyone affected for bearing with us.
Posted Sep 22, 2026 - 16:17 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2026 - 16:03 EDT
Update
We are continuing to investigate this issue.
Posted Sep 22, 2026 - 15:39 EDT
Update
A small number of customers in Wake Forest are currently offline, our techs are looking into the cause and we w ill update when we can.
Posted Sep 22, 2026 - 10:47 EDT
Investigating
Some customers in Wake Forest, NC are without internet service right now, and our engineers are already on it. We'll post an update here as soon as we have one.
Customers in the affected area don't need to restart anything — service will come back on its own once the fix is in. We appreciate everyone's patience while we work on this.
Posted Sep 22, 2026 - 10:34 EDT
This incident affects: North Carolina (Wake Forest, NC).