Ting Internet - Emergency Maintenance - Centennial, CO

Incident Report for Ting Internet

Resolved

This incident has been resolved. If customers are still experiencing issues, please power cycle your equipment. If this does not resolve the problem, please call support at 1-844-846-4994. Thank you.
Posted Mar 08, 2026 - 03:40 EDT

Monitoring

Service has been restored for most customers. We’re continuing to monitor the network.
We apologize for the disruption and appreciate your patience.
Posted Mar 08, 2026 - 03:16 EDT

Investigating

We are currently conducting emergency maintenance affecting customers in Centennial, CO. We apologize for this service disruption and thank you for your patience while we resolve this issue.
Posted Mar 08, 2026 - 01:10 EST
This incident affected: Colorado (Centennial, CO).