The network has been stable since service was restored, so we're closing this incident. Thanks again to everyone affected for their patience.
Any customer still offline can restart their router to bring the connection back.
Posted Sep 23, 2026 - 15:58 EDT
Update
Service is back. We've confirmed the affected connections in Greater Sandpoint, ID are online again, and we're keeping an eye on the network for a little while before we close this out.
Thanks to everyone affected for bearing with us.
Posted Sep 23, 2026 - 13:13 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 23, 2026 - 13:03 EDT
Update
Work is ongoing and the current ETR is 2 hours to complete the emergency maintenance. Thank you for your patience.
Posted Sep 23, 2026 - 11:07 EDT
Identified
Current ETR is 4 hours to complete the emergency maintenance. We will continue to provide updates here as we get them from our field team.
Posted Sep 23, 2026 - 09:10 EDT
Investigating
Our planned maintenance in Greater Sandpoint, ID has finished, but some customers are still without service. That's not what we planned, and the team is staying on it until everyone's back.
We'll update here as connections come back. There's nothing affected customers need to do — service will restore on its own. Thanks to everyone still waiting for bearing with us.
Posted Sep 23, 2026 - 09:02 EDT
This incident affected: Idaho (Greater Sandpoint, ID).