Ting Internet - Holly Springs, NC - Partial Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 11:42 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2025 - 11:30 EST

Investigating

Ting Internet engineers are investigating reports of an outage impacting service for some customers in the S MAIN ST area of Holly Springs, NC. We will post further information and next steps here as soon as it becomes available.
Posted Dec 04, 2025 - 11:14 EST
This incident affected: North Carolina (Holly Springs, NC).