Both towers have been restored. If you are still experiencing issues after this outage, please restart your dish by unplugging its power adapter, and plugging it back into power afterwards. If you are still having issues with connection after a restart, please contact our support. Thank you!
Posted Jul 16, 2026 - 03:29 EDT
Update
Loma Linda tower has been restored, and with it 59 customers are back online. Our engineers are still working on the remaining outage at Bigelow tower. 21 customers still affected.
Posted Jul 16, 2026 - 02:15 EDT
Identified
We have identified that a lightning strike has taken out some crucial components of our tower. Our infrastructure team is working at restoring a router at Loma Linda and power distribution units at both affected sites. No ETR available as of yet
Posted Jul 16, 2026 - 01:29 EDT
Investigating
We are currently investigating an outage stemming from two of our towers on Mt. Lemmon - Loma Linda, and Bigelow, affecting approximately 80 customers. Our infrastructure team is on route to the affected towers. Service is fully offline for all customers connected to these towers at the moment.