SimplyBits - Vail - Piano Mountain tower outage

Incident Report for Ting Internet

Resolved

We have identified the cause of the issue and replaced the equipment faulty equipment that triggered the problem. We have confirmed that power and all services are fully restored at our Piano Mountain Site. If your internet service has not automatically been restored, please power cycle your Simply Bits Power Over Ethernet Adapter that connects to the WAN/Internet port on your router, as well as the router itself.
Posted Mar 14, 2026 - 21:19 EDT

Investigating

We have dispatched a technician and going on site to investigate after being alerted that our tower went offline, affecting all the customers that depend on that tower in Vail. We are working to recover service as soon as possible, but do not have an ETA at this time.
Posted Mar 14, 2026 - 19:10 EDT
This incident affected: Arizona (Vail).