Our field crews have completed an initial assessment of the damage and determined that assistance from a specialized vendor will be required to complete the repairs.
At this time, we do not have an ETA for restoration. We expect to have additional information once the vendor arrives onsite and completes their assessment. Thank you for your patience
Posted Jun 24, 2026 - 12:10 EDT
Update
Ting field crews are currently onsite investigating the issue and assessing the extent of the damage. At this time, we do not have an ETA for full restoration, but we will provide updates and share an ETA as soon as one becomes available. Thank you for your patience.
Posted Jun 24, 2026 - 10:00 EDT
Investigating
We are currently investigating a service outage impacting some customers in the Holly Springs, NC market. Our team is working to identify the cause, and we will share updates as more information becomes available
Posted Jun 24, 2026 - 08:11 EDT
This incident affects: North Carolina (Holly Springs, NC).