Ting Internet - Partial Outage in Holly Springs NC.

Incident Report for Ting Internet

Resolved

All homes affected by this outage are up and online after repairs by our field team.
Posted May 28, 2026 - 16:23 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 28, 2026 - 14:33 EDT

Update

Field team is on-site and investigating
Posted May 28, 2026 - 13:55 EDT

Investigating

We are currently investigating an outage impacting service for a small number of customers within our Holly Springs, NC market. We will provide more information as it becomes available.
Posted May 28, 2026 - 12:30 EDT
This incident affected: North Carolina (Holly Springs, NC).