Ting Internet - Rolesville NC - Partial Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 16:08 EDT

Monitoring

We found the issue and made some repairs. All customers should be back online, if not, power cycle your ONT and Router. If you're still not online give us a call at 844-846-4994 for support. Will monitor this issue for a while before closing.
Posted Apr 14, 2026 - 15:39 EDT

Update

We are continuing to investigate this issue.
Posted Apr 14, 2026 - 14:28 EDT

Investigating

Ting Internet engineers are investigating reports of an outage impacting service for some customers in Rolesville NC. We will post further information and next steps here as soon as it becomes available.
Posted Apr 14, 2026 - 14:26 EDT
This incident affected: North Carolina (Rolesville, NC).