Charlottesville Mill Creek Area
Incident Report for Ting Internet
Resolved
This issue has been resolved.
Posted Jan 11, 2023 - 13:46 EST
Monitoring
We have identified the issue and have implemented a fix. Services should be back online. We will continue to monitor this situation.
Posted Jan 11, 2023 - 09:17 EST
Investigating
We are currently investigating an issue that is affecting a number of customers in the Mill Creek area of Charlottesville. We will continue to update as we know more.
Posted Jan 11, 2023 - 09:13 EST
This incident affected: Virginia (Charlottesville, VA).