This issue has been resolved and all but 2 customers are back online. If you are still offline please try rebooting your ONT and Router.
We appreciate your patience while we worked to identify and repair this issue.
We will continue to monitor this throughout the day.
Posted Sep 28, 2025 - 12:53 EDT
Update
We are still investigating the cause of this outage and will update when we have more information.
Thank you for your patience.
Posted Sep 28, 2025 - 11:20 EDT
Update
We are seeing a small outage in Fuquay Varina, NC impacting small amount of customers. We are still investigating the cause and will update when we have more information.
Thank you for your patience.
Posted Sep 28, 2025 - 08:43 EDT
Investigating
We are seeing a small outage in Fuquay Varina, NC impacting small amount of customers. We are still investigating the cause and will update when we have more information.
Please stand by while we investigate this further.
Posted Sep 28, 2025 - 05:46 EDT
This incident affected: North Carolina (Fuquay-Varina, NC).