We are aware of severe weather and a widespread power outage affecting the Charlottesville, VA area. As a result, some of our network equipment has lost power, impacting service for a significant number of customers.
Service is expected to be restored gradually as the local power utility restores electricity throughout the affected area. We are actively monitoring the situation and will provide updates as more information becomes available.
If you are still offline but have power, please power cycle your equipment. The Modem (ONT) mounted to the wall as well as your router.
Posted Jul 05, 2026 - 10:34 EDT
Identified
We are aware of severe weather and a widespread power outage affecting the Charlottesville, VA area. As a result, some of our network equipment has lost power, impacting service for a significant number of customers.
Service is expected to be restored gradually as the local power utility restores electricity throughout the affected area. We are actively monitoring the situation and will provide updates as more information becomes available.
Posted Jul 04, 2026 - 21:47 EDT
This incident affects: Virginia (Charlottesville, VA).