Ting Internet - Outage in Holly Springs, NC.

Incident Report for Ting Internet

Identified

Ting repair crews are on site and have identified the source of the damage. Based on an initial assessment, extensive work is required to replace the damaged conduit, and we have engaged specialized vendors to assist with the repairs.

Our current estimated time to restore service is 8:00 PM EST. We will provide another update once our vendor has completed a detailed assessment and we have a more precise restoration timeline. Thank you for your patience.
Posted Jun 11, 2026 - 11:07 EDT

Investigating

We are currently investigating a service outage impacting some customers in the Holly Springs, NC market. Our team is working to identify the cause, and we will share updates as more information becomes available.
Posted Jun 11, 2026 - 09:25 EDT
This incident affects: North Carolina (Holly Springs, NC).