Ting Web Site - Simply Bits residential customers seeing incorrect plan pricing
Incident Report for Ting Internet
Update
For Simply Bits customers who are seeing the incorrect amount for their monthly plan when they log in online, we have a workaround in place while we work to correct the issue for all impacted customers. If you are seeing the incorrect amount, you should be able to go to the invoices section of your online account and request an email a copy of your invoice which will show the proper billing amount. Thank you for your patience while we continue to work on correcting this issue.
Posted Dec 11, 2024 - 15:11 EST
Investigating
We have identified an issue with the Ting Website where Simply Bits Residential Customers in Arizona are not able to view the pricing for their current speed plan. All residential customers in this market who are currently using the Ting Web Portal to manage their accounts are currently seeing the price of $159.95 regardless of the actual plan they are on. Please be advised this issue will not impact your service in any way, and your pricing will remain the same as it has been. No actual changes to your plan or pricing have been made. We are currently investigating this issue with the web site and will post updates as they become available
Posted Dec 10, 2024 - 17:24 EST
This incident affects: Arizona (Tucson, Catalina, Amado, Douglas, Green Valley, Marana, Mt. Lemmon, Nogales, Oracle, Oro Valley, Rio Rico, Sahuarita, San Manuel, Tubac, Vail) and Ting Website, Shop & Your Account.