Centennial, CO - Intermittent Connectivity
Incident Report for Ting Internet
Resolved
At this time we have been able to resolve this issue. The last customers affected have been repaired and are online. If you are still experiencing issues with service please reboot your equipment. And if issues persist contact technical support at 844-846-4994.
Posted Feb 03, 2024 - 18:46 EST
Update
We are continuing to work on a fix for this issue.
Posted Jan 26, 2024 - 13:49 EST
Update
Due to the extremely cold temperatures over the last week in Centennial, Colorado, we are experiencing intermittent issues in certain neighborhoods due to the freezing of / condensation within certain conduits serving the area. You can rest assured we are working tirelessly to minimize the impact and we apologize for any inconvenience.

As we continue to monitor the situation, our field crews have been working diligently to try and restore services for all impacted customers and as weather conditions continue to fluctuate. If you recently experienced an issue with your service, please get in touch at 1-844-846-4994 so we can proceed with individual troubleshooting. We will continue to provide more updates as they become available and thank you for your patience.
Posted Jan 24, 2024 - 11:18 EST
Identified
Due to the extremely cold temperatures over the last week in Centennial, Colorado, we are experiencing intermittent issues in certain neighborhoods due to the freezing of / condensation within certain conduits serving the area. You can rest assured we are working tirelessly to minimize the impact and we apologize for any inconvenience. We will provide more updates as they become available.
Posted Jan 17, 2024 - 15:00 EST
This incident affected: Colorado (Centennial, CO).