Service Offline in Holly springs, NC

Incident Report for Ting Internet

Identified

Ting Internet engineers are continuing to work resolving an issue causing service slowness for some customers in Holly Springs. We hope to have full resolution shortly, thanks for your patience.
Posted Jul 24, 2026 - 11:11 EDT

Investigating

Some users may be experiencing service interruptions. Our team is actively investigating the root cause, and we expect a resolution shortly. Thank you for your patience.
Posted Jul 24, 2026 - 08:19 EDT
This incident affects: North Carolina (Holly Springs, NC).