Outage in CSCO

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 21:30 EDT

Update

We are investigating a possible internet outage in your local area. However, YouTube is currently experiencing a separate, widespread outage, but this does not affect your internet service over all. Please power cycle your ONT and Router and if the issue persists, outside of You Tube, please call 844-894-4994
Posted Oct 15, 2025 - 20:40 EDT

Investigating

We are currently seeing a handful of customers offline, we will update this page once we have more information, thank you
Posted Oct 15, 2025 - 19:44 EDT
This incident affected: Colorado (Colorado Springs, CO).