Emergency maintenance affecting customers in the Northwest area of Sandpoint

Incident Report for Ting Internet

Resolved

This incident has been resolved if customers are still having issues please power cycle your equipment if this does not resolve the issue please call support at 1-844-846-4994, thank you
Posted Feb 26, 2026 - 23:32 EST

Investigating

We are currently conducting emergency maintenance affecting customers in the Northwest area of Sandpoint. We apologize for this service disruption and thank you for your patience while we resolve this issue. Emergency maintenance will begin in 30 minutes.
Posted Feb 26, 2026 - 22:49 EST
This incident affected: Idaho (Greater Sandpoint, ID).