Outage in Centennial, CO

Incident Report for Ting Internet

Identified

We have located the failed piece of equipment and are on route to replace the piece of equipment. Please stand by as we continue to work on resolving the outage as soon as possible.

Thank you for your patience.
Posted Sep 25, 2026 - 22:17 EDT

Investigating

We are currently seeing some customers offline and are investigating the impact on our customers. Please stand by as we investigate and post information as it becomes available.

Thank you for your patience.
Posted Sep 25, 2026 - 20:19 EDT
This incident affects: Colorado (Centennial, CO).