Ting Internet - Charlottesville, VA - South Range MDU (1600 Jefferson Park Ave) Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 11:37 EST

Monitoring

The fix has been implemented and the issue has been resolved. If you are still seeing issues, please reboot your router. If that does not resolve your issue, please feel free to contact support at 1-844-846-4994 for individual troubleshooting.
Posted Feb 19, 2025 - 08:24 EST

Investigating

We are currently investigating an issue at South Range apartment building (1600 Jefferson Park Ave) in Charlottesville, VA with several customers there currently without service. We will provide more information as soon as it becomes available.
Posted Feb 18, 2025 - 20:52 EST
This incident affected: Virginia (Charlottesville, VA).