Some SimplyBits Customers Offline

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 13:18 EDT

Monitoring

A fix has been implemented and we are starting to see customer service restore. If you were affected and are still experiencing issues, please restart your router.

We're sorry for any inconvenience this caused!
Posted Jun 01, 2025 - 15:05 EDT

Identified

We have had reports from some customers regarding service going offline - the issue has been identified and is affecting customers connected to our Redington service tower.
SimplyBits engineers are working on resolution as soon as possible
Posted Jun 01, 2025 - 14:54 EDT
This incident affected: Arizona (Tucson).