All fiber splicing has been completed and all impacted customers have had their service restored at this time. If you are still experiencing issues, please reach out to our support team for further assistance.
Posted Jun 25, 2025 - 01:36 EDT
Update
Our technicians were able to blow the fiber quicker than anticipated so they have already begunb prepping and splicing the new fiber. That being said, the new anticipated time of restration is now approximately 9pm ET. We will provide further updates as they become available.
Posted Jun 24, 2025 - 19:41 EDT
Identified
Ting Internet engineers are on site at the location of a fiber cut. Based on our initial investigation, the tentative timeframe for restoration of service is 12:00 AM. We will provide further information as the work progresses. Thank you for your patience.
Posted Jun 24, 2025 - 13:04 EDT
Investigating
Ting Internet engineers are investigating reports of an outage affecting some customers in Fuquay-Varina, NC.
We will post further information as soon as it becomes available.
Posted Jun 24, 2025 - 12:04 EDT
This incident affected: North Carolina (Fuquay-Varina, NC).