A fix has been implemented and we are monitoring the results.
Posted Jun 13, 2025 - 13:46 EDT
Identified
Some reports from customers about fax still not working has brought us back to our initial investigation - still working on resolution.
Thank you again for your patience!
Posted Jun 12, 2025 - 18:01 EDT
Monitoring
We have been informed by our partner Lumen that the fax circuit has been repaired, and we are seeing successful faxes from some customers. We are continuing to monitor this issue until it's confirmed that all affected customers are back up and running!
Posted Jun 12, 2025 - 15:51 EDT
Identified
Our fax services partner is currently working on a fix, but hasn't provided an ETA on resolution as of yet. Testing with some customers is still showing some problems.
We are continuing to investigate and will continue to update here. Thank you for your continued patience!
Posted Jun 12, 2025 - 11:29 EDT
Investigating
We became aware today that our fax line with Lumen is down, affecting fax services for all our SimplyBits customers. We have made Lumen aware and they have dispatched technicians to resolve the issue, but we do not have an update with an ETA on when the service will be restored.