Colorado Springs, Colorado, Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted May 01, 2026 - 05:19 EDT

Monitoring

This was scheduled maintenance. The few customers affected should be online before 8 AM EST.
Posted May 01, 2026 - 05:16 EDT

Investigating

We seeing a small outage in Colorado Springs, Colorado at this time. Our team is investigating the cause and we will update when we have more.
Posted May 01, 2026 - 04:52 EDT
This incident affected: Colorado (Colorado Springs, CO).