We have resolved a power equipment failure by replacing a part which caused the outage. Our monitoring is showing a full restoration of service at this time. Thank you for your patience.
Posted Jan 13, 2026 - 13:45 EST
Update
Ting technicians are on site at our data center and working with our equipment vendor to troubleshoot the problem. Thank you for your patience while we work to restore service.
Posted Jan 13, 2026 - 13:05 EST
Identified
Ting technicians are on the way to our local data center to investigate our equipment and determine next steps for resolving the outage. We will post further information as soon as it becomes available.
Posted Jan 13, 2026 - 11:56 EST
Investigating
Ting Internet engineers are investigating reports of an outage impacting service for some customers in Culver City, CA. We will post further information and next steps here as soon as it becomes available.
Posted Jan 13, 2026 - 10:55 EST
This incident affected: California (Culver City, CA).