South Tucson Maintenance Noon - 2pm Mountain Time
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Sep 06, 2023 - 17:33 EDT
Identified
If you are a customer located in South Tucson, Milber and surrounding areas please be advised that during the hours of Noon and 2pm, Tucson time, customers in South Tucson will experience intermittent connectivity while we complete repairs following yesterday's Power Outage. We will continue to update our Alert page at www.simplybits.com, click on Network Health at the top of the page
Posted Aug 22, 2023 - 15:05 EDT
This incident affected: Arizona (Tucson).