Simply Bits: Tubac Arizona - Emergency Maintaintence being performed

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Oct 17, 2023 - 21:51 EDT

Identified

Please be advised that we are currently experiencing connectivity issues in Tubac Arizona and surrounding areas. Our Infrastructure Team is en route to perform emergency maintainance. Customers in these areas will experience Intermittent connectivity lasting until approximately 7pm Arizona Mountain Time. We apologize for any inconvenience this may cause, but appreciate your patience while we fully restore Services to our Simply Bits customers affected in these areas.
Posted Oct 17, 2023 - 17:10 EDT
This incident affected: Arizona (Tucson, Tubac).