Ting Internet - Cedar - Roaring Fork Region Outage

Incident Report for Ting Internet

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 14:33 EDT

Monitoring

A fix has been implemented and we are monitoring
Posted Jun 12, 2025 - 13:04 EDT

Identified

Our upstream provider has confirmed damage to their fiber causing the outage. It is impacting service for our customers in the Roaring Fork region of Colorado, particularly in Rifle, Silt, Glenwood Springs and New Castle. They are currently coordinating a fiber repair plan and we will provide more information as it becomes available.
Posted Jun 10, 2025 - 19:52 EDT

Investigating

We are currently investigating reports from multiple customers of a service outage affecting several customers in Rifle Colorado. We are still investigating the cause and the scope of the issue, and working with Lumen to resolve the issue. We currently do not have an ETA to resolve this yet.
Posted Jun 10, 2025 - 19:12 EDT
This incident affected: Colorado (Glenwood Springs, CO, New Castle, CO, Rifle, CO, Silt, CO).