Ting Internet - Fuquay-Varina, NC - Partial Outage (Village of Sippihaw area)

Incident Report for Ting Internet

Monitoring

Field Operations has confirmed that the damaged fiber has been successfully spliced and repaired. At this time, all previously offline services appear to be back online. If you are still experiencing any issues, please contact Ting Support at 1-844-846-4994 so we can assist with individual troubleshooting.
Posted May 23, 2025 - 18:17 EDT

Investigating

Ting Internet engineers are investigating an outage affecting customers in the Village of Sippihaw neighborhood of Fuquay-Varina, NC. We will provide further information as soon as possible.
Posted May 23, 2025 - 15:26 EDT
This incident affects: North Carolina (Fuquay-Varina, NC).