Simply Bits Network System Outage - Tucson and surrounding areas
Incident Report for Ting Internet
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 18:46 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 26, 2024 - 14:52 EDT
Identified
Today, April 26th, Simply Bits is currently experiencing Network wide system issues that may affect phones and internet connectivity. Our Engineering Team has identifed the issue, and is currently working on a swift resolution. We apologize for the inconvinience, but appreciate your patience during the investigation and repar.
Posted Apr 26, 2024 - 13:56 EDT
This incident affected: Arizona (Tucson).