We have placed a fix here. We are going to monitor this fix to confirm everything has stabilized. If you continue to have issues please restart your equipment.
Thank you for your ongoing patience.
Posted Jul 28, 2026 - 11:23 EDT
Identified
Our network engineers have identified the issue and are working closely with our field crews to restore service to all affected customers as quickly and safely as possible.
Posted Jul 28, 2026 - 10:50 EDT
Update
A fix has been implemented and services are restored. If you are still experiencing issues, please reboot your equipment by unplugging it for 30 seconds. If the reboot does not resolve the problem, please call support at 1-844-846-4994
Posted Jul 28, 2026 - 07:46 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2026 - 07:39 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 28, 2026 - 07:10 EDT
Investigating
We are currently experiencing a service disruption impacting some customers in the Greenbrier area. Our engineering team is actively investigating and working to resolve the issue. We apologize for the inconvenience.
Posted Jul 28, 2026 - 06:09 EDT
This incident affects: Virginia (Charlottesville, VA).