This incident has been resolved. If you're still experiencing issues, please reboot your router and fiber ONT. If the problem persists, contact our support team at 1-844-846-4994 so we can assist with individual troubleshooting.
Posted Jun 24, 2025 - 17:23 EDT
Update
They continue isolating the issue and working on bringing fiber service back into the homes. We will continue to update the status as information becomes available.
Posted Jun 21, 2025 - 04:48 EDT
Update
Currently, a tech is onsite investigating where the issue is, and we will continue to update you as more information becomes available.
Posted Jun 21, 2025 - 01:31 EDT
Update
We are investigating a reported outage in Memphis, TN. We will update as more information becomes available. A tech is now onsite.
Posted Jun 20, 2025 - 21:43 EDT
Investigating
We are investigating a reported outage in Memphis, TN. We will update as more information becomes available.